Some issues with processing on the TON exchanges

Incident Report for ChangeNow

Resolved

Hey!
Today, between 13:20 and 14:00 UTC, we experienced some delays with TON exchanges processing.

We're happy to let you know that the issue has now been fully resolved, and all affected exchanges have been processed. Everything is back to normal, but if you're still facing any issues, please don't hesitate to reach out.

We truly apologize for any inconvenience this may have caused and appreciate your patience!
Posted Apr 23, 2025 - 14:01 UTC

Investigating

Hello!
Since 13:20 UTC, we've been experiencing some issues with processing on the TON exchanges.

This means that you might see the status stuck on "Awaiting Deposit" and "sending to you" on the exchange page. Our tech team is already looking into it and working on a fix.

We'll keep you updated and let you know as soon as we have more info, which should be in about several hours.
Posted Apr 23, 2025 - 13:32 UTC
This incident affected: Digital Assets (Toncoin (TON)).