We are experiencing delays with processing exchanges on the confirmation stage

Incident Report for ChangeNow

Resolved

Just a heads-up — today, between 12:00 and 12:20 UTC, we had some delays with processing of exchanges on the confirmation stage.

Good news though — the issue has been sorted, and all the affected exchanges have been processed. Everything’s back to normal now, but if you're still having trouble, please let us know.

Sorry for the hassle, and thanks for your patience!
Posted Mar 10, 2026 - 12:24 UTC

Investigating

Hello!

Since 12:00 UTC we are experiencing delays with processing exchanges on the confirmation stage.
As a result, users may notice that there is no status change from "confirming" on the exchange page.
Our team is aware of the issue and is already on it. We will notify you ASAP once the issue is resolved.

We apologize for the inconvenience caused.
Posted Mar 10, 2026 - 12:12 UTC
This incident affected: Deposits.