Delays with ETHW exchanges processing.
Incident Report for ChangeNow
Resolved
This incident has been resolved.
Posted Sep 26, 2022 - 15:37 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 26, 2022 - 06:23 UTC
Update
Unfortunately, we are still experiencing delays with ETHW exchanges processing.

At the moment the team is working on the restoration of the service.
We will be back with an update within 60 minutes
Posted Sep 26, 2022 - 05:02 UTC
Update
Unfortunately, we are still experiencing delays with ETHW exchanges processing.

At the moment the team is working on the restoration of the service.
We will be back with an update within 5 hours.
Posted Sep 26, 2022 - 00:08 UTC
Identified
Unfortunately, we are still experiencing delays with ETHW exchanges processing.

At the moment the team is working on the restoration of the service.
We will be back with an update within 2 hours.
Posted Sep 25, 2022 - 22:10 UTC
Investigating
From 17:50 UTC we are experiencing issues with ETHW exchanges processing.
The issue happened due to an error in updating the data on the current liquidity balance of the payment service.
As a result, users may notice no status change from "exchanging" on the exchange page.

Our technical team is already working on a fix.
ETA is 2 hours.
Posted Sep 25, 2022 - 20:06 UTC