We are experiencing delays with USDTTRC20 payouts processing

Incident Report for ChangeNow

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 22:08 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 31, 2026 - 22:03 UTC

Identified

Hello!

Since 21:55 UTC, we're having some delays with USDTTRC20 payout processing.

Because of that, you might see the status stuck on "sending to you" and it won't update. Our tech team is on it and already working on a fix.

We’ll update you as soon as possible. Thanks for hanging in there!
Posted Jul 31, 2026 - 22:02 UTC

Investigating

Hello!

Since 21:55 UTC, we're having some delays with USDTTRC20 payout processing.

Because of that, you might see the status stuck on "sending to you" and it won't update. Our tech team is on it and already working on a fix.

We’ll update you as soon as possible. Thanks for hanging in there!
Posted Jul 31, 2026 - 21:59 UTC
This incident affected: Withdrawals.