Temporary issues with recognizing users' deposits and payouts processing.
Incident Report for ChangeNow
Resolved
Today from 18:15 to 19:25 UTC, we were experiencing issues with recognizing users' deposits, payouts processing, and partner rewards processing time.
We are happy to announce that the issue has been successfully resolved and the team is processing all affected exchanges.

At the moment the service is working as usual, but if you are still experiencing this issue, please let us know.
We sincerely apologize for the inconvenience caused.
Posted Jun 20, 2024 - 19:30 UTC
Update
Currently, the team has restored the functionality of almost all affected coins and associated transactions.
However, work is still underway to return LTC and DOGE.
We will provide an update as soon as we receive news.
Posted Jun 20, 2024 - 19:22 UTC
Identified
From 18:15 UTC we are experiencing issues with recognizing users' deposits, payouts processing, and partner rewards processing time due to unscheduled maintenance on our provider's side.
As a result, users and partners may notice no status change on the page.

Our technical team is working on a solution already.
We will get back to you with an update as soon as possible.
Posted Jun 20, 2024 - 18:39 UTC
This incident affected: Website (User Profile, Partners Profile) and Deposits, Exchange Processing.