Some issues with processing SEI exchanges.

Incident Report for ChangeNow

Resolved

Hey!
Yesterday, from 13:30 to today at 03:00 UTC, we experienced some delays with SEI exchanges processing.

We're happy to let you know that the issue has now been fully resolved, and all affected exchanges have been processed. Everything is back to normal, but if you're still facing any issues, please don't hesitate to reach out.

We truly apologize for any inconvenience this may have caused and appreciate your patience!
Posted Aug 21, 2025 - 08:22 UTC

Identified

Hello!
Since 13:30 UTC, we're having some issues with processing SEI exchanges.

Because of that, you might see the status stuck on "Awaiting deposit" and "Sending to you" and it won't update.
The issue is caused by the operation of the SEI network.

We’ll update you within several hours. Thanks for hanging in there!
Posted Aug 20, 2025 - 16:30 UTC