Temporary delays with BTC payouts processing
Incident Report for ChangeNow
Resolved
Today from 03:20 PM to 05:10 PM UTC we were experiencing delays with BTC payouts processing.

We are happy to announce that the problem has been successfully resolved, and all affected exchanges have been processed.
At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted Jan 19, 2023 - 17:13 UTC
Investigating
From 03:20 PM UTC, we are experiencing issues with BTC payouts processing.
As a result, users may notice that there is no status change from "sending to you" on the exchange page.
Our technical team is investigating the cause and is already working on a solution.
We will get back to you with an update within several hours.
Posted Jan 19, 2023 - 16:37 UTC
This incident affected: Digital Assets (Bitcoin (BTC)).