We are experiencing service disruption due to our server issues

Incident Report for ChangeNow

Resolved

Hello! Between 22:00 UTC and 22:40 we have been experiencing internal services disruptions. We are happy to announce that the server issues have been resolved, and our services are now operating normally.

Thank you for your patience and understanding while our technical team worked to resolve the troubles. We apologize for any inconvenience caused.
Posted Aug 11, 2026 - 22:49 UTC

Identified

Hello! Starting from 22:00 UTC we are experiencing issues with our servers, which may affect the availability and performance of some of our services.

Our technical team is investigating the issue and working to restore normal service as soon as possible.

We apologize for any inconvenience caused and will provide further updates as more information becomes available.
Posted Aug 11, 2026 - 22:04 UTC
This incident affected: Withdrawals, Deposits, and Exchange Processing.