Some delays with processing ADA exchanges

Incident Report for ChangeNow

Resolved

From 10:25 UTC on November 21st to 05:20 UTC on November 22nd we were experiencing delays with ADA exchange processing.

We are happy to announce that the problem has been successfully resolved, and all affected exchanges have been processed.
At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted Nov 22, 2025 - 05:27 UTC

Identified

Hello!
Since 10:25 UTC, we've been experiencing some delays with processing ADA exchanges due to network issues.

This means that you might see the status stuck on 'exchanging' on the exchange page.

We'll keep you updated and let you know as soon as we have more info, which should be in about several hours.
Posted Nov 21, 2025 - 10:30 UTC
This incident affected: Digital Assets (Cardano (ADA)).