Temporary issues with BNBBSC payouts processing

Incident Report for ChangeNow

Resolved

From 12:10 UTC to 12:50 UTC we were experiencing issues with BNBBSC payouts processing.

We are happy to announce that the problem has been successfully resolved, and the team is processing all affected exchanges.

At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.
We sincerely apologize for the inconvenience caused.
Posted Mar 20, 2025 - 12:57 UTC

Investigating

From 12:10 UTC you may experience issues with BNBBSC payouts processing.
As a result, users may notice that there is no status change from "sending to you" on the exchange page. The issue occurred due to a highly increased load on the payment service, which created a queue of payouts in the coin.

Our technical team is already working on a solution.
We will get back to you with an update as soon as we receive any news from the team.
Posted Mar 20, 2025 - 12:28 UTC
This incident affected: Digital Assets (BNB Smart Chain (BNBBSC), BNB Smart Chain (BNBBSC)).