Hey! Just a heads-up — today, between 16:10 and 17:30 UTC, we had some delays with processing PLS payouts.
Good news though — the issue has been sorted, and all the affected payouts have been processed. Everything’s back to normal now, but if you're still having trouble, please let us know.
Sorry for the hassle, and thanks for your patience!
Posted Mar 18, 2025 - 17:36 UTC
Investigating
From 16:10 UTC, we are experiencing issues with PLS payouts processing.
As a result, users may notice that there is no status change from "sending to you" on the exchange page. The issue occurred due to a highly increased load on the payment service, which created a queue of payouts. Our tech team is on it and already working on a fix.
We’ll update you as soon as we can. Thanks for hanging in there!
Posted Mar 18, 2025 - 16:22 UTC
This incident affected: Digital Assets (Pulsechain (PLS) (PLS)).