Terra Classic (LUNC) network update

Scheduled for Aug 15, 15:30 UTC  -  Aug 23, 23:30 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 15, 2025 - 05:58 UTC

Scheduled

We would like to notify you that on August 15th, from 15:30 (UTC), an upgrade will take place on the Terra Classic network. Due to the update, the LUNC token will be turned off.

We will also notify you immediately after the upgrade is over. We apologize for the inconvenience.
Posted Aug 14, 2025 - 22:20 UTC
This scheduled maintenance affects: Exchange Processing and Digital Assets (Terra Classic (LUNC)).