We are experiencing issues with payouts processing.

Incident Report for ChangeNow

Resolved

Today from 14:05 to 14:55 UTC we were experiencing delays with payouts processing.

We are happy to announce that the issue has been successfully resolved, and exchanges processing without any issues at the moment.

At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted Apr 17, 2025 - 14:56 UTC

Investigating

Since 14:05 UTC we are experiencing issues with payouts processing.

As a result, users and partners may notice that there is no status change from "sending to you" on the exchange page.
Our technical team is investigating the cause and is already working on a solution.

We’ll update you as soon as we can. Thanks for hanging in there!
Posted Apr 17, 2025 - 14:28 UTC
This incident affected: Exchange Processing.