Some issues with processing on the USDTTRC20 exchanges

Incident Report for ChangeNow

Resolved

Hey!
Today, between 16:00 and 16:30 UTC, we experienced some delays with USDTTRC20 exchanges processing.

We're happy to let you know that the issue has now been fully resolved. Everything is back to normal, but if you're still facing any issues, please don't hesitate to reach out.

We truly apologize for any inconvenience this may have caused and appreciate your patience!
Posted Apr 14, 2025 - 16:40 UTC

Investigating

Hello!
Since 16:00 UTC, we've been experiencing some issues with processing on the USDTTRC20 exchanges.

This means that you might see the status stuck on 'exchanging' on the exchange page. Our tech team is already looking into it and working on a fix.

We'll keep you updated and let you know as soon as we have more info, which should be in about several hours.
Posted Apr 14, 2025 - 16:11 UTC
This incident affected: Digital Assets (Tether (TRC20) (USDTTRC20)).