We're having some issues with processing TON exchanges

Incident Report for ChangeNow

Resolved

Hey!
Today, between 10:40 UTC and 12:40 UTC, we experienced some delays with TON exchanges processing.

We're happy to let you know that the issue has now been fully resolved. Everything is back to normal, but if you're still facing any issues, please don't hesitate to reach out.

We truly apologize for any inconvenience this may have caused and appreciate your patience!
Posted Apr 10, 2025 - 12:45 UTC

Identified

Hello!
Since 10:40 UTC, we've been experiencing some issues with processing on the TON exchanges.

This means that you might see the status stuck on 'exchanging' on the exchange page. Our tech team is already looking into it and working on a fix.

We'll keep you updated and let you know as soon as we have more info, which should be in about several hours.
Posted Apr 10, 2025 - 11:21 UTC
This incident affected: Exchange Processing and Digital Assets (Toncoin (TON)).