Delays with processing XDC exchanges due to network shutdown

Incident Report for ChangeNow

Resolved

This incident has been resolved.
Posted Dec 26, 2025 - 16:07 UTC

Identified

Hello! Just a heads-up: we are experiencing delays with processing XDC exchanges due to it's network shutdown since 00:00.

Because of this, you may see that the status stays stuck on "Awaiting Deposit" or "sending to you".

We are monitoring the situation and will return as soon as there are updates. Thanks for hanging in there!
Posted Dec 26, 2025 - 01:24 UTC
This incident affected: Withdrawals, Deposits, Exchange Processing and Digital Assets (XDC Network (XDC)).