Temporary delays with processing of exchanges

Incident Report for ChangeNow

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 14:26 UTC

Investigating

Hello!

Since 14:10 UTC, we have been experiencing some issues with processing of exchanges. The following assets are affected:
CAMPERC20, ELAERC20, ESERC20, EURQ, INJERC20, MX, NFTTRC20, ONDO, QTUM, USDQ, WAVES, XAUT, GT, ZBCN

This means that you may see the status "exchanging" on the exchange page stuck. Our technical team is already investigating the issue and working on a solution. We will keep you updated as soon as possible and let you know when we have more information.

Thank you for your patience and understanding!
Posted Feb 27, 2026 - 14:26 UTC
This incident affected: Digital Assets (Gatechain Token (GT), QTUM (QTUM), Injective (ERC20) (INJERC20), Quantoz EURQ (EURQ), MX Token (MX), Zebec Network (ZBCN), Elastos (ERC20) (ELAERC20), APENFT (Tron) (NFTTRC20), Tether Gold (XAUT), Waves (WAVES), Quantoz USDQ (USDQ), Camp Network (CAMPERC20), Ondo (ONDO)).