ETHW: issues with payouts processing
Incident Report for ChangeNow
Resolved
Today from 19:40 to 20:20 UTC we were experiencing delays with ETHW payouts processing.

We are happy to announce that the problem has been successfully resolved, and all affected exchanges have been processed.
At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted Sep 17, 2022 - 20:34 UTC
Investigating
Today from 19:40 UTC we are experiencing issues with ETHW payouts processing due to a network fee increase.
As a result, users may notice that there is no status change from "sending to you" on the exchange page.

We will get back to you with an update within 3 hours.
Posted Sep 17, 2022 - 19:55 UTC
This incident affected: Digital Assets (ETHPoW (ETHW)).