Experiencing delays with processing exchanges on the confirmation stage

Incident Report for ChangeNow

Resolved

This incident has been resolved.
Posted Jun 28, 2026 - 06:06 UTC

Investigating

Just a heads-up — today, between 05:20 and 05:40 UTC, we had some delays with processing of exchanges on the confirmation stage.

Good news though — the issue has been sorted, and all the affected exchanges have been processed. Everything’s back to normal now, but if you're still having trouble, please let us know.

Sorry for the hassle, and thanks for your patience!
Posted Jun 27, 2026 - 14:42 UTC
This incident affected: Deposits.