Some issues with deposits recognition and processing payouts

Incident Report for ChangeNow

Resolved

Hey! Just a heads-up — today, between 00:10 UTC and 05:00 UTC, we had some delays with deposits recognition and processing payouts.

Good news though — the issue has been sorted. Everything’s back to normal now, but if you're still having trouble, please let us know.

Sorry for the hassle, and thanks for your patience!
Posted Mar 11, 2025 - 05:02 UTC

Investigating

Hello!
Since 00:10 UTC, we're having some issues with deposits recognition and processing payouts.

Because of that, you might see the status stuck on ''awaiting deposit'' and "sending to you" and it won't update.
Our tech team is on it and already working on a fix.

We’ll update you within several hours. Thanks for hanging in there!
Posted Mar 11, 2025 - 00:21 UTC
This incident affected: Withdrawals and Deposits.