Temporary delays with BTC exchanges

Incident Report for ChangeNow

Resolved

Between 03:20 and 04:50 UTC today, we experienced a brief delay in processing BTC exchanges due to a temporary holdup in the creation of a new network block.

The good news is that a new BTC block has since been mined, and all pending exchanges have now been processed. Operations are fully back to normal. If you’re still encountering any issues, please don’t hesitate to reach out to us.

We sincerely apologize for the inconvenience and truly appreciate your patience and understanding!
Posted Apr 14, 2025 - 04:49 UTC

Identified

Hello!
We’re currently experiencing some temporary delays with BTC exchanges, starting at 03:20 UTC, due to a delay in the latest block on the network.

This means that you may notice delays in status updates on the affected exchanges page. Once the new block is created, everything will process as normal.

You can stay updated on the BTC network by checking this link: https://www.blockchain.com/btc/blocks?page=1.

We’ll send out another update as soon as the new block is confirmed. Thanks for your understanding!
Posted Apr 14, 2025 - 04:41 UTC
This incident affected: Exchange Processing and Digital Assets (Bitcoin (BTC)).