Delays with BNBBSC payouts processing.
Incident Report for ChangeNow
Resolved
This incident has been resolved.
Posted Sep 25, 2022 - 15:54 UTC
Investigating
We are experiencing temporary delays with BNBBSC payouts processing. Our team is already working on it, we’ll keep you updated.
Posted Sep 25, 2022 - 15:19 UTC