We are experiencing delays with processing exchanges on the exchanging stage

Incident Report for ChangeNow

Resolved

Hey! Today, between 21:10 and 22:50 UTC we were experiencing issues with processing exchanges on the exchanging stage.

The issue occurred due to the interruption in internal services connectivity. It now has been resolved, and all of the stuck exchanges were processed. We thank you for staying patient and understanding during this period!
Posted Feb 10, 2026 - 23:09 UTC

Identified

Hello! Since 21:10 we are experiencing delays with processing exchanges on the exchanging stage.

Our team is aware of the issue and is already on it. We will notify you ASAP once the issue is resolved.

We apologize for the inconvenience caused.
Posted Feb 10, 2026 - 21:18 UTC
This incident affected: Exchange Processing.