Delays with USDTTRC20 payouts processing.
Incident Report for ChangeNow
Resolved
Today from 18:30 to 19:40 UTC we were experiencing delays with USDTTRC20 payouts processing.

We are happy to announce that the problem has been successfully resolved, and all affected exchanges have been processed.
At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted Sep 22, 2022 - 19:45 UTC
Identified
We identified the reason for the delay with USDTTRC20 payouts processing.
The issue happened due to a technical error in the operation of the payment service, which led to the freezing of the transaction and the formation of a queue.

Our technical team is already working on a fix.
ETA is 3 hours.
Posted Sep 22, 2022 - 19:00 UTC
Investigating
From 18:30 UTC we are experiencing issues with USDTTRC20 payouts processing.
As a result, users may notice that there is no status change from "sending to you" on the exchange page.
Our technical team is investigating the cause and is already working on a solution.
We will get back to you with an update within 15 minutes.
Posted Sep 22, 2022 - 18:38 UTC
This incident affected: Exchange processing and Digital Assets (Tether (TRC20) (USDTTRC20)).