We are experiencing issues with USDTERC20 payouts processing

Incident Report for ChangeNow

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 18:44 UTC

Investigating

Hello! From 17:35 UTC we are experiencing issues with USDTERC20 payouts and partner rewards processing.

As a result, users may notice that there is no status change from "sending to you" on the exchange page.

We will get back to you with an update as soon as possible.
Posted Feb 10, 2026 - 18:13 UTC
This incident affected: Digital Assets (Tether (ERC20) (USDTERC20)).