Temporary delays with processing XTZ, ADA, EGLD and others

Incident Report for ChangeNow

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 13:13 UTC

Investigating

Hello,
Currently we experience temporary delays with processing few assets, due to the technical difficulties. Affected assets: mon, usdcmon, apt, cakeapt, usdtapt, usdcapt, usdtapt, seievm, usdcseievm, opbnb, usdtopbnb.
Posted Jul 29, 2026 - 03:33 UTC
This incident affected: Withdrawals, Deposits, and Exchange Processing.