SEI and SEI EVM network outage

Incident Report for ChangeNow

Resolved

This incident has been resolved.
Posted May 02, 2026 - 23:51 UTC

Investigating

Hello!

Since 17:00 UTC, we have been experiencing delays in processing SEI and SEI EVM exchanges due to network outages. As a result, users may notice that the status on the exchange page is not updating.

We will notify you as soon as the issue is resolved.
Posted May 02, 2026 - 18:04 UTC
This incident affected: Digital Assets (Sei (SEI), Sei EVM (SEIEVM)).