We are experiencing issues with USDTTRC20 payouts processing

Incident Report for ChangeNow

Resolved

From 17:45 UTC to 20:30 UTC we were experiencing issues with USDTTRC20 payouts processing.

The incident has been resolved and all the affected exchanges were processed!

Thank you for your patience.
Posted Jan 14, 2026 - 20:32 UTC

Identified

Hello! From 17:45 UTC we are experiencing issues with USDTTRC20 payouts processing.

As a result, users may notice that there is no status change from "sending to you" on the exchange page.

We will get back to you with an update as soon as possible.
Posted Jan 14, 2026 - 18:15 UTC
This incident affected: Withdrawals and Digital Assets (Tether (TRC20) (USDTTRC20)).