We're having some issues with BSC and tokens exchange processing and payouts

Incident Report for ChangeNow

Update

Hey team!

Today, between 12:29 UTC and 14:07 UTC, we experienced delays with processing BSC and tokens exchanges.

We're happy to let you know that the issue has now been fully resolved, and all affected exchanges have been processed. Everything is back to normal, but if you're still facing any issues, please don't hesitate to reach out.

We truly apologize for any inconvenience this may have caused and appreciate your patience!
Posted Aug 21, 2026 - 14:13 UTC

Investigating

Hello!

Since 12:29 UTC we are experiencing issues with BSC and tokens exchange processing and payouts.
As a result, users may notice no status change from "waiting" and "sending to you" on the exchange page.
Our technical team is already working on a solution. We’ll update you as soon as we can.

Thanks for hanging in there!
Posted Aug 21, 2026 - 13:02 UTC
This incident affects: Digital Assets (Tether (Binance Smart Chain) (USDTBSC)).