Today, between 16:30 (UTC) and 17:40 UTC, we had some temporary issues with partner balances
We’re happy to let you know that the issue has been fixed, and the service is back to normal. If you're still experiencing any problems, please don’t hesitate to reach out.
We truly apologize for any inconvenience this caused, and we appreciate your patience!
Posted Nov 08, 2025 - 17:45 UTC
Update
We are continuing to investigate this issue.
Posted Nov 08, 2025 - 17:09 UTC
Investigating
Hello everyone,
Just a heads-up: starting at 16:30 (UTC), we are experiencing some temporary issues with partner balances. There are might be delays with processing conversions and rewards, but exchange processing are not affected.
Our technical team is investigating the cause and is already working on a solution. We will get back to you with an update as soon as we will receive it from the team. Thanks for your understanding, and we apologize for any inconvenience this may cause!
Posted Nov 08, 2025 - 16:59 UTC
This incident affected: Website (Partners Profile) and Withdrawals.