Delays with processing of Polygon network tokens exchanges due to network shutdown

Incident Report for ChangeNow

Resolved

Today we had some issues with processing of POLYGON and POLYGON Network tokens exchanges due to POL network shutdown.

The issue is now fixed, and the network is stable. Sorry for the inconvenience, and thanks for your patience!
Posted Dec 18, 2025 - 03:41 UTC

Identified

Hello! Just a heads-up: we are experiencing delays with processing of POLYGON and POLYGON tokens exchanges due to POL network shutdown since 18:30.

Because of this, you may see that the status stays stuck on "Awaiting Deposit" or "sending to you".

We are monitoring the situation and will return as soon as there are updates. Thanks for hanging in there!
Posted Dec 17, 2025 - 19:30 UTC
This incident affected: Withdrawals, Deposits, and Exchange Processing.