We're having some issues with processing XMR exchanges

Incident Report for ChangeNow

Resolved

Hey!

As you might remember, today between 23:40 UTC and 00:05 UTC, we had some issues with processing XMR exchanges.

Good news though — the issue has been resolved.
The issue occurred due to a malfunction in communication between internal services.
Everything’s back to normal now, but please let us know if you’re still having trouble.

Sorry for the hassle, and thanks for your patience!
Posted Apr 22, 2025 - 00:09 UTC

Identified

Since 23:30 UTC we are experiencing issues with processing XMR exchanges.

As a result, users and partners may notice that there is no status change from "exchanging" on the exchange page.
The issue occurred due to a malfunction in communication between internal services.

We’ll update you as soon as we can. Thanks for hanging in there!
Posted Apr 21, 2025 - 23:52 UTC
This incident affected: Exchange Processing and Digital Assets (Monero (XMR)).