Temporary issues with live chat and email support handling

Incident Report for ChangeNow

Resolved

Hey! Just a heads-up — today, between 14:40 and 16:50 UTC, we had some delays with live chat and email support handling.

Good news though — the issue has been sorted and everything’s back to normal now.

Sorry for the hassle, and thanks for your patience!
Posted Dec 12, 2025 - 16:58 UTC

Investigating

Hey everyone,

Since 14:40 UTC we’re currently facing some temporary issues with live chat and email support handling. Due to the problem, we are temporarily experiencing delays in processing support requests.
We are closely monitoring the situation and trying to restore our services as soon as possible.

Thank you for your patience and understanding.
Posted Dec 12, 2025 - 15:05 UTC
This incident affected: Website (Website) and Customer Support.