Delays with the performance of our Website
Incident Report for ChangeNow
Resolved
This incident has been resolved.
Posted Dec 02, 2022 - 16:53 UTC
Identified
At the moment we are experiencing delays with the performance of our Website. Our team is already working on it.
We apologize for any inconvenience.
Posted Dec 02, 2022 - 13:37 UTC
This incident affected: Website (Website).