Temporary delays with BTC payouts processing
Incident Report for ChangeNow
Resolved
Today from 16:14 to 17:05 UTC we were experiencing delays with BTC payouts processing.

We are happy to announce that the problem has been successfully resolved, at the moment the team is working on finishing all affected exchanges.
At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted Dec 05, 2022 - 17:12 UTC
Investigating
We are experiencing issues with BTC payouts processing.
As a result, users may notice that there is no status change from "sending to you" on the exchange page.
Our technical team is investigating the cause and is already working on a solution.
Posted Dec 05, 2022 - 16:30 UTC