Today, from 07:00 to 10:00 (UTC), there was scheduled technical maintenance on the side of our liquidity provider.
We are happy to announce that the technical maintenance has been successfully completed.
At the moment the service is working as usual.
Posted Aug 06, 2025 - 10:05 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 06, 2025 - 07:00 UTC
Scheduled
Hello there, Just a quick heads-up: on August 6, starting at 07:00 (UTC), we might experience temporary delays with USDC, USDCMATIC, USDCARB, USDCBASE, and USDCOP payouts due to scheduled maintenance by our liquidity provider.
During this time, you may notice that the status on the exchange page stays stuck on "exchanging" or "sending to you."
Please note, these delays are just a possibility and might not happen at all. Our service is fully prepared for the maintenance, and we don't expect it to affect your exchanges.
We'll keep you updated and let you know once everything is back to normal. Thanks for your understanding, and we apologize for any inconvenience this may cause!