Some issues with processing MATIC network transactions

Incident Report for ChangeNow

Resolved

Hey! Just a heads-up — today, between 07:15 and 08:05 UTC, we had some issues with processing MATIC network transactions.

Good news though — the issue has been sorted, and all the affected payouts have been processed. Everything’s back to normal now, but if you're still having trouble, please let us know.

Sorry for the hassle, and thanks for your patience!
Posted Aug 01, 2025 - 08:10 UTC

Investigating

Hello!
Since 07:15 UTC, we've been experiencing some issues with processing MATIC network transactions.

This means that you might see the status stuck on "Awaiting deposit" and "Sending to you" on the exchange page. The issue is caused by the operation of the MATIC network. Our tech team is already looking into it and working on a fix.

We'll keep you updated and let you know as soon as we have more info, which should be in about several hours.
Posted Aug 01, 2025 - 07:20 UTC
This incident affected: Digital Assets (Polygon (Matic Mainnet) (MATICMAINNET)).