We are experiencing issues with processing exchanges in MATIC network

Incident Report for ChangeNow

Resolved

Hey!
Today between 11:25 and 16:40 UTC, we had some issues with processing MATIC network transactions.

The issue is now fixed, and all the unprocessed exchanges have been completed. Everything should be working fine now, but if you're still having problems, please let us know.

Thanks for your patience!
Posted Jul 30, 2025 - 16:44 UTC

Investigating

From 11:25 UTC we are experiencing issues with processing payouts in MATIC network.

As a result, users may notice no status change from "sending to you" on the exchange page.
Our technical team is investigating the cause and is already working on a solution.

We will get back to you with an update as soon as we receive any news from the team.
Posted Jul 30, 2025 - 11:47 UTC
This incident affected: Digital Assets (Polygon (Matic Mainnet) (MATICMAINNET), USD Coin Bridged (Polygon) (USDCMATIC)).